您的位置:首页 > 编程语言 > PHP开发

hdoj 1092 A+B for Input-Output Practice (IV)

2014-07-27 23:53 393 查看
/*

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 62274 Accepted Submission(s): 33527

Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4

5 1 2 3 4 5

0

Sample Output

10

15

*/

#include<stdio.h>

int main()

{

int n,sum;

while(scanf("%d",&n),n)

{

sum=0;

while(n--)

{

int i;

scanf("%d",&i);

sum=sum+i;

}

printf("%d\n",sum);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: