您的位置:首页 > 其它

poj 3083 Children of the Candy Corn

2012-07-31 16:34 204 查看
Children of the Candy Corn

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6638Accepted: 2899
Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom
the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding
visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze
layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also
be separated by at least one wall ('#').

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one
square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########


Sample Output
37 5 5
17 17 9


Source

South Central USA 2006

#include <stdio.h>
#include <string.h>
int w,h;
int r,l,m;
int si,sj,di,dj,ok;
char as[100][100];
int dx[4]={0,-1,0,1};
int dy[4]={-1,0,1,0};
int bs[100][100];
int judge1(int cur)
{
    if(cur==1) return 0;
    if(cur==2) return 1;
    if(cur==3) return 2;
    return 3;
}
int judge2(int cur)
{
    if(cur==1) return 2;
    if(cur==2) return 3;
    if(cur==3) return 0;
    return 1;
}
void dfs(int x,int y,int kd,int cur,int cnt)
{
    if(x<0||y<0||x>=h||y>=w||as[x][y]=='#') return;
    if(kd==1)
    {
       if((x==di)&&(y==dj))
       {
           l=cnt;
           ok=1;
           return ;
       }
       int T=0;
       cur=judge1(cur);
       while(T<4)
       {
           int xx=x+dx[cur];
           int yy=y+dy[cur];
           if(xx<0||yy<0||xx>=h||yy>=w||as[xx][yy]=='#');
           else break;
           ++cur;
           cur%=4;
           T++;
       }
       dfs(x+dx[cur],y+dy[cur],kd,cur,cnt+1);
    }
    if(kd==2)
    {
        if((x==di)&&(y==dj))
        {
            r=cnt;
            ok=1;
            return ;
        }
        int T=0;
        cur=judge2(cur);
        while(T<4)
        {
            int xx=x+dx[cur];
            int yy=y+dy[cur];
            if(xx<0||yy<0||xx>=h||yy>=w||as[xx][yy]=='#');
            else break;
            --cur;
            cur=(cur+4)%4;
            T++;
        }
        dfs(x+dx[cur],y+dy[cur],kd,cur,cnt+1);
    }
    if(kd==3)
    {
        if(m<=cnt||bs[x][y]<=cnt)
        return;
        bs[x][y]=cnt;
        if((x==di)&&(y==dj))
        {
            m=cnt;
            return;
        }
        int T=0;
        as[x][y]='#';
        cur=judge2(cur);
        while(T<4)
        {
            dfs(x+dx[cur],y+dy[cur],kd,cur,cnt+1);
            ++cur;
            cur%=4;
            T++;
        }
    }
    as[x][y]='.';
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
       scanf("%d%d",&w,&h);
       l=r=0;
       for(i=0;i<h;++i) scanf("%s",as[i]);
       for(i=0;i<h;++i)
       for(j=0;j<w;++j)
       {
           if(as[i][j]=='S')
           {
               si=i;
               sj=j;
           }
           else if(as[i][j]=='E')
           {
               di=i;
               dj=j;
           }
           bs[i][j]=10000;
       }
       ok=0;
       dfs(si,sj,1,-1,1);
       ok=0;
       dfs(si,sj,2,-1,1);
       m=l>r?r:l;
       dfs(si,sj,3,-1,1);
       printf("%d %d %d\n",l,r,m);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: