您的位置:首页 > 其它

poj 3083 -- Children of the Candy Corn

2014-08-01 16:13 337 查看
Children of the Candy Corn

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9544Accepted: 4136
Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will
eventually find the exit. Simply choose either the right or left wall,
and follow it. Of course, there's no guarantee which strategy (left or
right) will be better, and the path taken is seldom the most efficient.
(It also doesn't work on mazes with exits that are not on the edge;
those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a
maze, you'd like to have a computer program that can determine the left
and right-hand paths along with the shortest path so that you can
figure out which layout has the best chance of confounding visitors.
Input

Input
to this problem will begin with a line containing a single integer n
indicating the number of mazes. Each maze will consist of one line with a
width, w, and height, h (3 <= w, h <= 40), followed by h lines of
w characters each that represent the maze layout. Walls are represented
by hash marks ('#'), empty space by periods ('.'), the start by an 'S'
and the exit by an 'E'.

Exactly one 'S' and one 'E' will be present in the maze, and they
will always be located along one of the maze edges and never in a
corner. The maze will be fully enclosed by walls ('#'), with the only
openings being the 'S' and 'E'. The 'S' and 'E' will also be separated
by at least one wall ('#').

You may assume that the maze exit is always reachable from the start point.
Output

For
each maze in the input, output on a single line the number of (not
necessarily unique) squares that a person would visit (including the 'S'
and 'E') for (in order) the left, right, and shortest paths, separated
by a single space each. Movement from one square to another is only
allowed in the horizontal or vertical direction; movement along the
diagonals is not allowed.
Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9


思路:依次DFS出右转左转的步数,BFS出最小步数。。


/*======================================================================
*           Author :   kevin
*         Filename :   ChildrwenOftheCandyCorn.cpp
*       Creat time :   2014-06-08 15:37
*      Description :
========================================================================*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#define clr(a,b) memset(a,b,sizeof(a))
#define M 50
using namespace std;
char grap[M][M];
int w,h,sx,sy,ex,ey;
int vis[M][M],cntl,cntr;
int minsteps[M][M];
int dir0[4][2]={{0,-1},{-1,0},{0,1},{1,0}};//dfs needed
int dir[4][4][2] = {//bfs needed
{{0,-1},{-1,0},{0,1},{1,0}},
{{-1,0},{0,1},{1,0},{0,-1}},
{{0,1},{1,0},{0,-1},{-1,0}},
{{1,0},{0,-1},{-1,0},{0,1}}
};
struct Node
{
int x,y;
};
void BFS()
{
queue<Node>que;
Node node;
node.x = sx; node.y = sy;
que.push(node);
vis[sx][sy] = 1;
minsteps[sx][sy] = 1;
int flag = 0;
while(que.empty() != true){
Node T = que.front();
que.pop();
if(T.x == ex && T.y == ey) return ;
for(int i = 0; i < 4; i++){
int x = T.x + dir[1][i][0];
int y = T.y + dir[1][i][1];
if(grap[x][y] == '.' && !vis[x][y]){
node.x = x; node.y = y;
vis[x][y] = 1;
que.push(node);
minsteps[x][y] = minsteps[T.x][T.y]+1;
}
else if(grap[x][y] == 'E'){
minsteps[x][y] = minsteps[T.x][T.y]+1;
flag = 1; break;
}
}
if(flag) break;
}
}
int lDFS(int i,int j,int s,int now)
{
if(grap[i][j]=='E')return s;
for(int d=now;d<now+4;++d)
{
int di=i+dir0[d%4][0];
int dj=j+dir0[d%4][1];
if(d<=0)d+=4;
if(grap[di][dj]!='#')return lDFS(di,dj,s+1,(d-1)%4);
d%=4;
}
return -1;
}
int rDFS(int i,int j,int s,int now)
{
if(grap[i][j]=='E')return s;
for(int d=now+4;d>now;--d)
{
int di=i+dir0[d%4][0];
int dj=j+dir0[d%4][1];
if(grap[di][dj]!='#')return rDFS(di,dj,s+1,(d+1)%4);
}
return -1;
}
int main(int argc,char *argv[])
{
int cas;
scanf("%d",&cas);
while(cas--){
scanf("%d%d",&w,&h);
clr(vis,0);
memset(grap,'#',sizeof(grap));
clr(minsteps,0);
for(int i = 1; i <= h; i++){
getchar();
for(int j = 1; j <= w; j++){
scanf("%c",&grap[i][j]);
if(grap[i][j] == 'S'){
sx = i; sy = j;
}
if(grap[i][j] == 'E'){
ex = i; ey = j;
}
}
}
printf("%d %d ",lDFS(sx,sy,1,0),rDFS(sx,sy,1,0));
BFS();
printf("%d\n",minsteps[ex][ey]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: