您的位置:首页 > 其它

hdu 2058 The sum problem(数学题)

2015-05-31 20:28 459 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2058

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18137 Accepted Submission(s): 5385



Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.


Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.


Sample Input
20 10
50 30
0 0



Sample Output
[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]


【分析】

每组输入两个数n,m

问从1~n 个数中有多少连续区间的和等于m,如果等于,输出该区间

容易想到等差数列的公式 Sn=(a1+an)*n /2

也许高中时讲过上面公式的变形 Sn=a1*n+(n-1)*n*d/2; (Sn=(a1+a1+(n-1)*d)*n/2 =
a1*n+(n-1)*n/2)

又因为本题d=1; Sn=a1*n+(n-1)*n/2;

对于任意这样的等差数列,什么时候n最大呢?

显然当a1=1的时候 n最大, 所以,化简一下,此时的Sn*2 = n*(n-1);

也就是说 n小于 sqrt(Sn*2);

所以我们只要把n从最大到1进行遍历求解就行了,(时间上大大的优化了)

因 a1*n + n(n-1)/2 = Sn;

所以我们设 b = Sn - n*(n-1)/2;

那么只要 b % n == 0 那么就找到了所求区间 【b/n+1,b/n+n】,该区间元素和等于Sn;

【代码如下】

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		if(n==0&&m==0)
			break;
		for(int i=sqrt(m*2);i>0;i--)
		{
			int b=(m-(i*i+i)/2);
			if(b%i==0)
			{
				printf("[%d,%d]\n",b/i+1,b/i+i);
			}
		}
		printf("\n");
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: