您的位置:首页 > 其它

HDU 2058 The sum problem

2014-07-26 09:20 92 查看


The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15122 Accepted Submission(s): 4529



Problem Description

Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input

20 10
50 30
0 0


Sample Output

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]


Author

8600

Source

校庆杯Warm Up

Recommend

linle | We have carefully selected several similar problems for you: 2066 2065 1238 1708 1418

Statistic | Submit | Discuss | Note

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
//枚举字串的长度
int main()
{
int n,m,i;
while(scanf("%d%d",&n,&m)!=EOF&&(n!=0||m!=0))
{
for(int j=sqrt(2*m);j>=1;j--)
{
i=((2*m)/j+1-j)/2;
if((i+i+j-1)*j==2*m)
printf("[%d,%d]\n",i,i+j-1);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: