您的位置:首页 > 理论基础 > 计算机网络

Number Sequence&&http://acm.hdu.edu.cn/showproblem.php?pid=1005

2012-01-05 14:59 656 查看

Number Sequence

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 48952 Accepted Submission(s): 10923
[/b]

[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

[align=left]Input[/align]
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0

[align=left]Sample Output[/align]

2
5一看这题的时间要求就知道常规的方法肯定不行了,,于是把目标锁定在mod7上,想了好打一会mod7这说明f(n)的取值仅在0-6之间,,那就是说如果给定一组a和b后F
共有49种取法所以周期肯定小于49,因此这题找到周期就ok了AC代码
#include<iostream>
using namespace std;
int f[50];
int main()
{ int a,b,m,i;
while(cin>>a>>b>>m&&a&&b&&m)
{ f[1]=f[2]=1;
for(i=3;i<=50;++i)
{
f[i]=((a*f[i-1])%7+(b*f[i-2])%7)%7;
if(f[i]==f[i-1]&&f[i-1]==1) break;
}
i=i-2;
m%=i;
if(m) cout<<f[m]<<endl;
else  cout<<f[i]<<endl;
}return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  input signal each output