您的位置:首页 > 理论基础 > 计算机网络

二分查找求函数的区间最小值&&http://acm.hdu.edu.cn/showproblem.php?pid=2899

2012-03-27 15:08 706 查看

Strange fuction

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 792 Accepted Submission(s): 607
[/b]

[align=left]Problem Description[/align]
Now, here is a fuction:

F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

[align=left]Output[/align]
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

[align=left]Sample Input[/align]

2
100
200

[align=left]Sample Output[/align]

-74.4291
-178.8534AC代码:
#include<iostream>
#include<cmath>
#include<cstdio>
#define exp 1e-7
using namespace std;
double f(double x)
{ return  42*pow(x,6.0)+48*pow(x,5.0)+21*pow(x,2.0)+10*x;}
double f1(double x,int a)
{return 6*pow(x,7.0)+8*pow(x,6.0)+7*pow(x,3.0)+5*pow(x,2.0)-a*x;}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int a;
scanf("%d",&a);
double l=0.0,r=100.0,mid;
while(r-l>exp)
{
mid=(l+r)/2;
if(f(mid)>a) r=mid-exp;
else      l=mid+exp;
}
printf("%.4lf\n",f1(mid,a));
}return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  integer numbers input each up