您的位置:首页 > 编程语言 > PHP开发

1007 DNA Sorting

2011-12-18 16:27 120 查看
DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 60694 Accepted: 23968
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input
10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT


Sample Output
CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA


Source

East Central North America 1998

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
struct O {
char a[55];
int num;
}list[105];

bool cmp(const O &x,const O &y) {
return x.num<y.num;
}
int i,j,k,n,m;

int main() {
cin >> n >> m;
for(i=0; i<m; i++) {
cin >> list[i].a;
list[i].num = 0;
for(j=0; j<n; j++) {
for(k=j; k<n; k++) {
if(list[i].a[j] > list[i].a[k])
list[i].num++;
}
}
}
sort(list,list+m,cmp);
for(i=0; i<m; i++) {
cout << list[i].a << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息