您的位置:首页 > 其它

acm pku 1007 DNA Sorting

2008-04-03 12:55 302 查看
[align=center]DNA Sorting[/align]

Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA



#include<iostream>


#include<algorithm>




using namespace std;




char dna[100][51];




struct DNA




...{


char s[50];


int num;


};


struct sort_f




...{


bool operator() (DNA d1,DNA d2)




...{


if(d1.num!=d2.num)


return d1.num<d2.num;


return strcmp(d1.s,d2.s)<0;


}


};


int main()




...{


int n,m,a,c,g,t;


DNA dna[100];


cin>>m>>n;


for(int pi=0;pi<n;++pi)




...{


cin>>dna[pi].s;


dna[pi].num=0;


}


for(int pj=0;pj<n;++pj)




...{


a=0,c=0,g=0,t=0;


for(int pk=m-1;pk>=0;--pk)




...{


if(dna[pj].s[pk]=='A')




...{


++a;


}


else if(dna[pj].s[pk]=='C')




...{


dna[pj].num+=a;


++c;


}


else if(dna[pj].s[pk]=='G')




...{


dna[pj].num+=a+c;


++g;


}


else if(dna[pj].s[pk]=='T')




...{


dna[pj].num+=a+c+g;


++t;


}


}


}


sort_f sf;


sort(dna,dna+n,sf);


for(int i=0;i<n;++i)


cout<<dna[i].s<<endl;


return 0;


}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: