您的位置:首页 > 编程语言 > PHP开发

poj 2155(二维树状数组)

2011-07-12 21:47 309 查看
Matrix

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 9672Accepted: 3636
Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 

2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1 2 10 C 2 1 2 2 Q 2 2 C 2 1 2 1 Q 1 1 C 1 1 2 1 C 1 2 1 2 C 1 1 2 2 Q 1 1 C 1 1 2 1 Q 2 1 

Sample Output

1 0 0 1

这题是比较经典的二维树状数组,题意是给你个矩阵里面开始全是0,然后给你两种指令:1:‘C x1,y1,x2,y2’就是将左上角为x1,y1,右下角为x2,y2,的这个矩阵内的数字全部翻转,0变1,1变0,;2:'Q x1 y1',输出a[x1][y1]的值。这题的巧妙只初在于重叠消元,将要翻转的矩阵的四个角更新一遍就ok了,去掉重叠部分(结果模2),刚好剩下了这个矩阵翻转了,用笔画画就知道了,刚开始我直接令x1-x2,y1-y2,更新,wa了,想了想好像不行,有些更新不到,举例,从8直接到16中间那部分更新不到。

下面是我的代码。。。

#include<cstdio>
#include<string>
#include<iostream>
#define N 1005
int c

,n;
int bit(int n)
{
return n&(-n);
}
int sum(int x,int y)
{
int ans=0;
for(int i=x;i>0;i-=bit(i))
for(int j=y;j>0;j-=bit(j))
{
ans+=c[i][j];
}
return ans;
}
void up(int x,int y,int k)
{
for(int i=x;i<=n;i+=bit(i))
for(int j=y;j<=n;j+=bit(j))
{
c[i][j]+=k;
}
}
int main()
{
int cc,t,x1,x2,y1,y2,a,b;
char ch;
scanf("%d",&cc);
for(int i=0;i<cc;i++)
{
memset(c,0,sizeof(c));
scanf("%d%d",&n,&t);
getchar();
for(int j=0;j<t;j++)
{
scanf("%c",&ch);
if(ch=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
getchar();
up(x1,y1,1);
up(x1,y2+1,1);
up(x2+1,y1,1);
up(x2+1,y2+1,1);
}
else
{
scanf("%d%d",&a,&b);
getchar();
printf("%d\n",sum(a,b)%2);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息