您的位置:首页 > 其它

POJ 2155 Matrix(二维树状数组)

2016-08-03 19:56 357 查看
Matrix

Time Limit: 3000MS Memory Limit: 65536K

Total Submissions: 24595 Accepted: 9106

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1

2 10

C 2 1 2 2

Q 2 2

C 2 1 2 1

Q 1 1

C 1 1 2 1

C 1 2 1 2

C 1 1 2 2

Q 1 1

C 1 1 2 1

Q 2 1

Sample Output

1

0

0

1

Source

POJ Monthly,Lou Tiancheng

想复习一下树状数组,结果随便挑挑了一题这么玄的。。。

关于这道题玄学方法的解释在:

http://download.csdn.net/detail/lenleaves/4548401

里面说的很清楚,其他无非就是二维树状数组的东西了

#include <cstdio>
#include <string.h>
#include <iostream>
#include <cstring>
using namespace std;
int matrix[1005][1005];
int n;
int lowbit(int x)
{
return x&(-x);
}

void update(int x,int y)
{
for(int i=x;i<=n;i+=lowbit(i))
{
for(int j=y;j<=n;j+=lowbit(j))
matrix[i][j]+=1;
}
}
int sum(int x,int y)
{
int ans=0;
for(int i=x;i>0;i-=lowbit(i))
for(int j=y;j>0;j-=lowbit(j))
ans+=matrix[i][j];
return ans;
}

int main()
{
int cas;
scanf("%d",&cas);
while(cas--)
{
int t;
scanf("%d%d",&n,&t);
memset(matrix,0,sizeof(matrix));
char op[10];
for(int i=1;i<=t;i++)
{
scanf("%s",op);
if(op[0]=='C')
{
int x1,x2,y1,y2;
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
update(x1,y1);
update(x1,y2+1);
update(x2+1,y1);
update(x2+1,y2+1);
}
else
{
int x,y;
scanf("%d%d",&x,&y);
printf("%d\n",sum(x,y)%2);
}

}
printf("\n");

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: