您的位置:首页 > 其它

POJ3889【Fractal Streets】(递归与回溯)

2020-08-24 15:19 232 查看

链接:http://poj.org/problem?id=3889

题目描述:
With a growing desire for modernization in our increasingly larger cities comes a need for new street designs. Chris is one of the unfortunate city planners responsible for these designs. Each year the demands keep increasing, and this year he has even been asked to design a completely new city.
More work is not something Chris needs right now, since like any good bureaucrat, he is extremely lazy. Given that this is a character trait he has in common with most computer scientists it should come as no surprise that one of his closest friends, Paul, is in fact a computer scientist. And it was Paul who suggested the brilliant idea that has made Chris a hero among his peers: Fractal Streets! By using a Hilbert curve, he can easily fill in rectangular plots of arbitrary size with very little work.
A Hilbert curve of order 1 consists of one “cup”. In a Hilbert curve of order 2 that cup is replaced by four smaller but identical cups and three connecting roads. In a Hilbert curve of order 3 those four cups are in turn replaced by four identical but still smaller cups and three connecting roads, etc. At each corner of a cup a driveway (with mailbox) is placed for a house, with a simple successive numbering. The house in the top left corner has number 1, and the distance between two adjacent houses is 10m.
The situation is shown graphically in figure 2. As you can see the Fractal Streets concept successfully eliminates the need for boring street grids, while still requiring very little effort from our bureaucrats.

As a token of their gratitude, several mayors have offered Chris a house in one of the many new neighborhoods built with his own new scheme. Chris would now like to know which of these offerings will get him a house closest to the local city planning office (of course each of these new neighborhoods has one). Luckily he will not have to actually drive along the street, because his new company “car” is one of those new flying cars. This high-tech vehicle allows him to travel in a straight line from his driveway to the driveway of his new office. Can you write a program to determine the distance he will have to fly for each offier (excluding the vertical distance at takeoff and landing)?

输入描述:
On the first line of the input is a positive integer, the number of test cases. Then for each test case:
A line containing a three positive integers, n < 16 and h, o < 231, specifying the order of the Hilbert curve, and the house numbers of the offered house and the local city planning office.

输出描述:
For each test case:
One line containing the distance Chris will have to fly to his work in meters, rounded to the nearest integer.

输入样例:

3
1 1 2
2 16 1
3 4 33

输出样例:

10
30
50

题意:
计算n阶分形街道中给定两点的直线距离

数据范围:
n < 16,两点 h,o < 2^31

思路:
先用递归函数求出起点和终点坐标
再用距离公式求出答案
分析递归:
n = 1时
第一个点坐标(1,1)
第二个点坐标(1,2)
第三个点坐标(2,2)
第四个点坐标(2,1)
n > 1时
在右上角和右下角各放置一个n-1
在左上角放置顺时针旋转90度的n-1
在左下角放置逆时针旋转90度的n-1

代码:

#include<cstdio>
#include<cmath>
typedef long long ll;
ll p[40];//代表第n级分形图编号总数
void rec(ll n,ll s,ll &x,ll &y)//第n级编号为s坐标(x,y)
{
if(n==1)
{
if(s==1)x=1,y=1;
else if(s==2)x=1,y=2;
else if(s==3)x=2,y=2;
else x=2,y=1;
return;
}
if(s<=p[n-1])rec(n-1,s,y,x);
else if(s<=2*p[n-1])rec(n-1,s-p[n-1],x,y),y+=(1<<n-1);
else if(s<=3*p[n-1])rec(n-1,s-2*p[n-1],x,y),x+=(1<<n-1),y+=(1<<n-1);
else rec(n-1,s-3*p[n-1],y,x),x=(1<<n)+1-x,y=(1<<n-1)+1-y;
}
int main()
{
int t;
ll n,s,e,sx,sy,ex,ey;
scanf("%d",&t);
p[1]=4;
for(int i=2;i<=33;i++)p[i]=4*p[i-1];
while(t--)
{
scanf("%lld%lld%lld",&n,&s,&e);
rec(n,s,sx,sy);//分别求出s和e的坐标
rec(n,e,ex,ey);
printf("%.0f\n",sqrt((sx-ex)*(sx-ex)+(sy-ey)*(sy-ey))*10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: