您的位置:首页 > 产品设计 > UI/UE

Subsequence(连续字段和最小并且大于S)

2020-07-16 06:07 886 查看

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and
a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the
subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input
Many test cases will be given. For each test case the program has to read the numbers N and S,
separated by an interval, from the first line. The numbers of the sequence are given in the second line
of the test case, separated by intervals. The input will finish with the end of file.

Output
For each the case the program has to print the result on separate line of the output file.

Sample Input
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3
题目大概意思:连续字段和最小并且大于S!
本质上还是一道前缀和的题目!

#include <cstring>
#include <cstdio>
#include <iostream>
using namespace std;
typedef long long LL;
const int N = 1e5 + 10;
int a[N];

int solve(int n, int s)
{
int res = n + 1;
int start = 0, end = 0, sum = 0;
for(;;)
{
while(end < n && sum < s)
sum += a[++ end];

//为什么要写sum < s才可退出循环,两个原因
//1.此条件可保证遍历完全部的a[i],也就是O(n)的
//2.由于上边的while循环所导致,所以sum只有遍历完之后才会break
if(sum < s) break;

res = min(res, end - start);
sum -= a[++ start];
}
return res > n ? 0 : res;
}

int main()
{
int n, s;
while(cin >> n >> s)
{
for(int i = 1; i <= n; i ++ ) cin >> a[i];

cout << solve(n, s) << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐