您的位置:首页 > 产品设计 > UI/UE

POJ 3061:Subsequence 查找连续的几个数,使得这几个数的和大于给定的S

2015-10-07 15:37 495 查看
Subsequence

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10172Accepted: 4160
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3


题意是给出一个序列,要求从这个序列中找出几个连续的数,使得这些数的和大于给定的S,求这个数的最小值。

和51nod上面的建设国家很像,都是建立一个队列,然后不断查找。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

long long n,s,a[1000005];

int main()
{
//freopen("i.txt","r",stdin);
//freopen("o.txt","w",stdout);

int test,i,ans,start;
long long sum;
scanf("%d",&test);

while(test--)
{
scanf("%lld%lld",&n,&s);
for(i=1;i<=n;i++)
{
scanf("%lld",a+i);
}
ans=n+1;
a[0]=0;
sum=0;
start=1;
for(i=1;i<=n;i++)
{
sum += a[i];
while(sum>s)
{
sum = sum - a[start];
start++;
}
if(sum+a[start-1]>s && i-(start-1)+1<ans)
{
ans=i-(start-1)+1;
}
}
if(ans == n+1)
{
cout<<0<<endl;
}
else
{
cout<<ans<<endl;
}
}
//system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: