您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2016-07-29 09:58 288 查看


数据结构实验之链表七:单链表中重复元素的删除




Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^



题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


输入

第一行输入元素个数n; 

第二行输入n个整数。


输出

第一行输出初始链表元素个数; 

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。


示例输入

10
21 30 14 55 32 63 11 30 55 30



示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21



提示


来源

不得使用数组!

#include<stdio.h>
#include<iostream>
using namespace std;
int n;
struct node
{
int  d;
node *next;
};

node *CreatList(int n)      //逆序建表
{
node *head=new node;  //    // head=(node *)malloc(sizeof(node));
head->next=NULL;

for(int i=0; i<n; i++)
{
node * p=new node;
cin>>p->d;
p->next=head->next;
head->next=p;
}
return head;
}

node *DeleteList(node *head)        //删除重复的元素
{
node *p=head->next;
while(p!=NULL)
{
node *q=p;
node *k=q->next;
while(k!=NULL)
{
if(k->d==p->d)
{
q->next=k->next;
n--;
}
else q=q->next;
k=q->next;
}
p=p->next;
}
return head;
}
void PrintList(node *head)
{
node *p=head->next;
while(p!=NULL)
{
if(p->next==NULL)
cout<<p->d<<endl;
else
cout<<p->d<<" ";
p=p->next;
}
}
int main()
{
cin>>n;
node *head=NULL;
head=CreatList(n);
cout<<n<<endl;
PrintList(head);
head=DeleteList(head);
cout<<n<<endl;
PrintList(head);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐