您的位置:首页 > 其它

1133 Splitting A Linked List(25 分)

2018-09-06 14:01 302 查看
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Wchenchen0/article/details/82460254

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

[code]Address Data Next

where 

Address
 is the position of the node, 
Data
 is an integer in [−10​5​​,10​5​​], and 
Next
 is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

[code]00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

[code]33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

 

 

其实这题不用map也行,把地址当成结构数组的下标即可

 

[code]#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;

struct node
{
int next;
int data;
};
vector<int>p[3];
int main()
{
int adress, n, k;
scanf("%d %d %d", &adress, &n, &k);
map<int, node>L;
for (int i = 0;i < n;i++) {
int x, y, z;
scanf("%d %d %d", &x, &y, &z);
L[x].data = y;
L[x].next = z;
}
int first = adress;
while (first != -1) {
if (L[first].data < 0) p[0].push_back(first);
else if (L[first].data >= 0 && L[first].data <= k) p[1].push_back(first);
else p[2].push_back(first);
first = L[first].next;
}
int flag = 0;
for (int i = 0;i < 3;i++) {
for (int j = 0;j < p[i].size();j++) {
if (flag == 0) {
printf("%05d %d ", p[i][j], L[p[i][j]].data);
flag = 1;
}
else {
printf("%05d\n%05d %d ", p[i][j], p[i][j], L[p[i][j]].data);
}
}
}
printf("-1\n");
return 0;
}

 

阅读更多
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: