您的位置:首页 > 其它

1133. Splitting A Linked List (25)

2018-03-11 18:28 369 查看
Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.Input Specification:Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=1000). The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.Then N lines follow, each describes a node in the format:Address Data Nextwhere Address is the position of the node, Data is an integer in [-105, 105], and Next is the position of the next node. It is guaranteed that the list is not empty.Output Specification:For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100010;
struct Node{
int v;
int add,next;
}all[maxn],low[maxn],mid[maxn],high[maxn],valid[maxn];
int main()
{
int root,n,k;
scanf("%d%d%d",&root,&n,&k);
for(int i=0;i<n;i++)
{
int add;
scanf("%d",&add);
scanf("%d%d",&all[add].v,&all[add].next);
all[add].add=add;
}
int p=root,lnum=0,mnum=0,hnum=0,num=0;
while(p!=-1)
{
if(all[p].v<0)low[lnum++]=all[p];
else if(all[p].v<=k)mid[mnum++]=all[p];
else high[hnum++]=all[p];
p=all[p].next;
}
for(int i=0;i<lnum;i++)
{
valid[num++]=low[i];
}
for(int i=0;i<mnum;i++)
{
valid[num++]=mid[i];
}
for(int i=0;i<hnum;i++)
{
valid[num++]=high[i];
}
for(int i=0;i<num-1;i++)
{
printf("%05d %d %05d\n",valid[i].add,valid[i].v,valid[i+1].add);
}
printf("%05d %d -1\n",valid[num-1].add,valid[num-1].v);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  链表