您的位置:首页 > 其它

PAT (Advanced Level)-1133 Splitting A Linked List

2018-08-23 16:44 134 查看

1133 Splitting A Linked List(25 分)

PAT (Basic Level)-1075 链表元素分类

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where 

Address
 is the position of the node, 
Data
 is an integer in [−10​5​​,10​5​​], and 
Next
 is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

[code]#include <iostream>
#include <vector>

using namespace std;

struct q
{
int address,data,next;
}buf[100001];
vector<q>v,res;
int main()
{
int h,n,k,i;
int addr,data,next;
cin>>h>>n>>k;
for(i=0;i<n;i++)
{
scanf("%d %d %d",&addr,&data,&next);
buf[addr].address=addr;
buf[addr].data=data;
buf[addr].next=next;
}
while(h!=-1)
{
v.push_back(buf[h]);
h=buf[h].next;
}
for(auto &x:v)
{
if(x.data<0)
{
res.push_back(x);
}
}
for(auto &x:v)
{
if(x.data>=0&&x.data<=k)
{
res.push_back(x);
}
}
for(auto &x:v)
{
if(x.data>k)res.push_back(x);
}
for(i=0;i<res.size()-1;i++)
{
res[i].next=res[i+1].address;
}
res[res.size()-1].next=-1;
for(i=0;i<res.size();i++)
{
if(i==res.size()-1)printf("%05d %d %d\n",res[i].address,res[i].data,res[i].next);
else printf("%05d %d %05d\n",res[i].address,res[i].data,res[i].next);
}

}

 

阅读更多
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: