您的位置:首页 > 其它

POj 3461 Oulipo ,HDU 1686 Oulipo(KMP)

2018-03-31 21:17 465 查看
题目链接:http://poj.org/problem?id=3461
题目链接:http://hdu.hustoj.com/showproblem.php?pid=1686

[align=left]Problem Description[/align]The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 
[align=left]Input[/align]The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 
[align=left]Output[/align]For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 
[align=left]Sample Input[/align]
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN 
[align=left]Sample Output[/align]
1
3

题意:
求第一个串在第二个串中出现的次数,KMP模板题,直接上板子
代码:#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>
#include<map>

using namespace std;

#define FOU(i,x,y) for(int i=x;i<=y;i++)
#define FOD(i,x,y) for(int i=x;i>=y;i--)
#define MEM(a,val) memset(a,val,sizeof(a))
#define PI acos(-1.0)

const double EXP = 1e-9;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const ll MINF = 0x3f3f3f3f3f3f3f3f;
const int mod = 1e9+7;
const int N = 1e6+5;

int Next[10005];
char mo
;
char str
;

void Get_next()
{
int len=strlen(mo);
int j=-1;
Next[0]=-1;
int i=0;
while(i<len)
{
while(j!=-1&&mo[i]!=mo[j])
j=Next[j];
Next[++i]=++j;
}
}

//返回模式串在主串S中出现的次数
int Kmp_count()
{
int len1=strlen(str);
int len2=strlen(mo);
int ans=0;
int i=0,j=0;
while(i<len1)
{
while(str[i]!=mo[j]&&j!=-1)
j=Next[j];
i++;
j++;
if(j>=len2)
{
ans++;
j=Next[j];
}
}
return ans;
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
std::ios::sync_with_stdio(false);
int t;
scanf("%d",&t);
while(t--)
{
scanf(" %s %s",mo,str);
Get_next();
Kmp_count();
printf("%d\n",Kmp_count());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ HDU KMP