您的位置:首页 > 其它

poj 3461 Oulipo (KMP||hash)

2016-08-02 15:20 471 查看
Oulipo

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35267 Accepted: 14255
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

这题要注意计算数量时要返回的最前面相同的前缀,所以next数组长度要扩展到字符串长度

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
const int N = 2000010;
char str1[2*N], str2
;
void getnext();
int kmpsearch();
int len1, len2, nex
, cnt;

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s %s",str1, str2);
len1=strlen(str1);
len2=strlen(str2);
getnext();
cnt=0;
printf("%d\n",kmpsearch());
}
return 0;
}

void getnext()
{
int k=-1,j=0;
nex[0]=-1;
while(j<len1)
{
if(k==-1||str1[k]==str1[j])
{
k++;j++;
if(str1[k]!=str1[j])
{
nex[j]=k;
}
else
{
nex[j]=nex[k];
}
}
else
{
k=nex[k];
}
}
return ;
}

int kmpsearch()
{
int k=0,j=0;
while(j<len2)
{
if(k==-1||str1[k]==str2[j])
{
j++,k++;
}
else
{
k=nex[k];
}
if(k==len1)
{
cnt++;
k=nex[k];
}
}
return cnt;
}


unsigned long long超范围后会自动对2^64取模,省去了手动取模.

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <string>
using namespace std;
const int N = 1e6+10;
map<string,int>q;
char str
, s
;
typedef unsigned long long LL;
const LL seed=100;

int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%s %s",str, s);
LL a1=0, a2=0, l1=1;
int len1=strlen(str), len2=strlen(s);
if(len1>len2)
{
printf("0\n");
continue;
}
int cnt=0;
for(int i=0;i<len1;i++)
{
a1=a1*seed+(str[i]-'A'+1);
a2=a2*seed+(s[i]-'A'+1);
l1*=seed;
}
if(a1==a2) cnt++;
for(int i=len1;i<len2;i++)
{
a2=a2*seed-(s[i-len1]-'A'+1)*l1+(s[i]-'A'+1);
if(a2==a1) cnt++;
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: