您的位置:首页 > 其它

hdu 2095 find your present (2)

2018-03-26 15:25 375 查看

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27135    Accepted Submission(s): 10635


[align=left]Problem Description[/align] In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others. 
[align=left]Input[/align] The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input. 
[align=left]Output[/align] For each case, output an integer in a line, which is the card number of your present. 
[align=left]Sample Input[/align]
5
1 1 3 2 2
3
1 2 1

[align=left]Sample Output[/align]
3
2

HintHint
use scanf to avoid Time Limit Exceeded 
[align=left]Author[/align] 8600

方法一:利用STL中的set很容易想到方法:如果是当前存入的数在集合中已存在,则把集合中的这个数给删了,这样偶数个的总会被删完,只留一下一个奇数的就是需要的结果。
//hdu 2095 find your present (2)
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
#include <set>
#include <algorithm>

using namespace std;
set<int> it;

int main(){
int n;
int a;
while(scanf("%d", &n) != EOF && n){
for(int i = 0; i < n; i++){
scanf("%d", &a);
if(it.find(a) == it.end()){
it.insert(a);
}
else
it.erase(a);
}
printf("%d\n", *it.begin());
it.clear();
}
return 0;
}
方法二:利用离散异或的知识知道,
《1》偶数个相同的数异或结果是0;
《2》奇数个相同的数异或结果是这个数本身;
《3》0与任何数异或的这个数;
这样我们就有方法了,对于输入的n个数全部进行异或,这样留下的就是那个出现奇数次的那个数了,就是我们要的结果。//hdu 2095 find your present (2)
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
#include <set>
#include <algorithm>

using namespace std;

int main()
{
int n,x,ans;
while(scanf("%d",&n),n)
{
ans = 0;
while(n--)
{
scanf("%d",&x);
ans ^= x;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: