您的位置:首页 > 其它

hdu 2095 find your present (2)

2014-08-11 10:10 344 查看
[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present
has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present
will be the one with the card number of 3, because 3 is the number that different from all the others.

[align=left]Input[/align]
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0


[align=left]Sample Output[/align]

3
2
哈希超时超内存,用位运算较巧妙
//由于题意说只有一个数出现奇数次,说明其他数都是偶数次。
//于是用异或运算符,同一个数偶数次异或是0,奇数次异或就是本身。
#include <stdio.h>
int main()
{
int n, i, a, r;
while(~scanf("%d", &n), n)
{
r = 0;
for(i = 0; i < n; i++)
{
scanf("%d", &a);
r ^= a;
}
printf("%d\n", r);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: