您的位置:首页 > 其它

算法竞赛宝典 分治算法 交叉的梯子(几何公式的推导+二分)

2018-03-25 09:35 288 查看
Crossed ladders
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5209 Accepted: 1980
DescriptionA narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street? 


InputEach line of input contains three positive floating point numbers giving the values of x, y, and c.OutputFor each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.Sample Input30 40 10
12.619429 8.163332 3
10 10 3
10 10 1
Sample Output26.033
7.000
8.000
9.798
SourceThe UofA Local 2000.10.14//理解二分边界处理+几何推导,这个就不难了,重点还是在边界总结:做了几道类似的之后,二分对精度的处理都是,循环条件用精度划分,在二分时,直接left=mid,这样去处理#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>

using namespace std;
double x,y,c;
bool f(double w)
{
double a,b;
a=sqrt(x*x-w*w);
b=sqrt(y*y-w*w);
if(a*b>=c*(a+b))
return 0;
else
return 1;
}
int main()
{
while(cin>>x>>y>>c)
{
double left=0,right=x>y?y:x,mid;       //意思是以最短的楼梯作为街宽的最大然后进行二分
while(right-left>1e-4)
{
mid=left+(right-left)/2.0;
if(f(mid)==0)
left=mid;
else
right=mid;
}
printf("%.3lf\n",left);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: