您的位置:首页 > 其它

hdu5878 I Count Two Three(水题)

2018-03-20 20:22 302 查看
hdu5878 I Count Two Three(水题)

I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It's interesting that the i-th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2^a3^b5^c7^d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n.  

Input

The first line of input contains an integer t (1≤t≤500000), the number of test cases. t test cases follow. Each test case provides one integer n (1≤n≤109).  

Output

For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n.  

Sample Input

1011113123123412345123456123456712345678123456789  

Sample Output

11214125125012348123480123480012348000123480000  

Source

2016 ACM/ICPC Asia Regional Qingdao Onlin

题意:给出一个整数
n
, 找出一个大于等于
n
的最小整数
m
, 使得
m
可以表示为
2^a * 3^b * 5^c * 7^d​​
.题解:打表预处理出所有满足要求的数

#include <iostream>
#include <cstdio>
#include <algorithm>
#define N 10000
#define ll long long

using namespace std;

int arr
;

ll pow(ll a, ll b)//快速幂
{
ll ans = 1;
while(b)
{
if(b & 1)ans *= a;
a *= a;
b>>=1;
}
return ans;
}

int main()
{
ll tmp; int cnt = 0;
for(int a = 0; a < 31; a++)
{
for(int b = 0; b < 20; b++)
{
for(int c = 0; c < 14; c++)
{
for(int d = 0; d < 12; d++)
{
tmp = pow(2, a)*pow(3, b);
if(tmp > 1e9)break;
tmp *= pow(5, c);
if(tmp > 1e9)break;
tmp *= pow(7, d);
if(tmp > 1e9)break;
arr[cnt++] = tmp;
}
}
}
}
sort(arr, arr+cnt);
int T, n;
scanf("%d", &T);
while(T--)
{
scanf("%d", &n);
int pos = lower_bound(arr, arr+cnt, n)-arr;
printf("%d\n", arr[pos]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: