您的位置:首页 > 其它

HDU5878 I Count Two Three【打表+排序+二分搜索】

2017-11-29 22:41 519 查看

I Count Two Three

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2222    Accepted Submission(s): 978


[align=left]Problem Description[/align]
I will show you the most popular board game in the Shanghai Ingress Resistance Team.

It all started several months ago.

We found out the home address of the enlightened agent Icount2three and decided to draw him out.

Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.

It's interesting that the i-th
attacks failed if and only if i can
be rewritten as the form of 2a3b5c7d which a,b,c,d are
non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I
Count Two Three Numbers".

A related board game with a given positive integer n from
one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n.
 

[align=left]Input[/align]
The first line of input contains an integer t (1≤t≤500000),
the number of test cases. t test
cases follow. Each test case provides one integer n (1≤n≤109).
 

[align=left]Output[/align]
For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n.
 

[align=left]Sample Input[/align]

10
1
11
13
123
1234
12345
123456
1234567
12345678
123456789

 

[align=left]Sample Output[/align]

1
12
14
125
1250
12348
123480
1234800
12348000
123480000

 

[align=left]Source[/align]
2016
ACM/ICPC Asia Regional Qingdao Online

问题链接HDU5878 I Count Two Three


问题分析:打表、排序和搜索问题。

程序说明:样例没有通过(1是1,程序运行结果是2),但是程序AC了,有点奇怪啊!!!

题记:能用库函数要尽量使用库函数。

参考链接51Nod-1010 只包含因子2 3 5的数【打表+排序+二分搜索】

AC的C++程序如下:

/* HDU5878 I Count Two Three */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int TWO = 2;
const int THREE = 3;
const int FIVE = 5;
const int SEVEN = 7;

const long MAXN = 1e9 + 100;
const int N = 1e6;
long long a
;
int m;

void maketable()
{
m = 0;
for(long long i=1; i<MAXN; i*=TWO) {
for(long long j=1; j*i<MAXN; j*=THREE) {
for(long long k=1; i*j*k<MAXN; k*=FIVE) {
for(long long l=1; i*j*k*l<MAXN; l*=SEVEN) {
a[m++] = i * j * k * l;
}
}
}
}
}

int main()
{
maketable();
sort(a, a + m);

int t;
long long n;

scanf("%d", &t);
while(t--) {
scanf("%lld", &n);
printf("%lld\n", *lower_bound(a + 1, a + m, n));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: