您的位置:首页 > 运维架构

PAT Advanced 1044. Shopping in Mars (25)

2018-03-17 16:48 447 查看
题目描述:

1044. Shopping in Mars (25)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.Input Specification:Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.Output Specification:For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.It is guaranteed that the total value of diamonds is sufficient to pay the given amount.Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5

直接用两个指针p1,p2,p1在前面对输入的元素的前n项和逐个遍历,p2在后面和p1指针保持一定的距离(由题设条件给出,在本题中,两指针的距离应该满足 *p1-*p2<=M),最后在原数组中输出所用满足条件的p1-p2。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
#include<bits/stdc++.h>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
//	freopen("data.txt","r",stdin);
int n,m,x,s=0;
scanf("%d %d",&n,&m);
vector<int> v0(n+1);
vector<int> v;
v0.push_back(0);
int j=0;
int mi=99999;
bool flag=true;
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
s=s+x;
v0[i]=s;
for(;s-v0[j]>m;++j);
if(s-v0[j]==m)
{
flag=false;
printf("%d-%d\n",j+1,i);
}
else if(flag)
{
if(j>0&&v0[i]-v0[j-1]-m>0)
{
if(mi>v0[i]-v0[j-1]-m)
{
v.clear();
mi=v0[i]-v0[j-1]-m;
v.push_back(j);
v.push_back(i);
}
else if(v0[i]-v0[j-1]-m==mi)
{
v.push_back(j);
v.push_back(i);
}
}
}
}
if(flag)
for(int i=0;i<v.size()/2;i++)
{
printf("%d-%d\n",v[2*i],v[2*i+1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT ADVANCED