您的位置:首页 > 运维架构

PAT(A) - 1044. Shopping in Mars (25)

2016-12-03 10:26 387 查看
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the
chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).

2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).

3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has
to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds.
All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order
of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again
all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:
1-5
4-6
7-8
11-11

Sample Input 2:
5 13
2 4 5 7 9

Sample Output 2:
2-4
4-5


思路分析:考查二分,先将输入的数据打表到数组,这样会是一个升序的序列,然后利用二分的特性找到目标值。我直接使用的lower_bound和upper_bound库函数。没怎么用过这俩东西......debug了好久才AC。

lower_bound返回的是第一个大于等于目标值的数组元素指针,如果是容器则返回迭代器。

upper_bound返回的是第一个大于目标值的数组元素指针,如果是容器返回迭代器。

另外binary_search返回的是1或0,即真或徦。找到返回真,没找到返回假,不能返回数组下标。

#include <cstdio>
#include <algorithm>
#include <vector>

#define MAX 100000
#define INF 0x3fffffff

using namespace std;

int a[MAX];
int minDiff = INF;

int main() {
int n, m;

scanf( "%d%d", &n, &m );

int num;
for( int i = 1; i <= n; i++ ) {
scanf( "%d", &num );
a[i] = a[i - 1] + num;
}

//vector<int>::iterator low;
int *low;

for( int i = 1; i <= n; i++ ) {
// 从第i个序号开始枚举连续的子序列,找到第一个大于等于m的位置
int start = i;
//low = lower_bound( a.begin(), a.end(), m + a[start - 1] );
low = lower_bound( a + 1, a + n + 1, m + a[start - 1] );
if( ( low - a ) <= n && ( *low - a[start - 1] ) < minDiff ) {
minDiff = *low - a[start - 1];
}
//rintf( "%d-%d\n", start, low - a, *low - a[start - 1] );
}

//printf( "%d\n", minDiff );

int *upp;
for( int i = 1; i <= n; i++ ) {
int start = i;
//int pos = binary_search( a + 1, a + 1 + n, a[start - 1] + m + minDiff );
//printf( "%d\n", m + a[start - 1] + minDiff );
upp = upper_bound( a + 1, a + n + 1, a[start - 1] + minDiff );
if( *( upp - 1 ) - a[start - 1] == minDiff ) {
printf( "%d-%d\n", start, upp - a - 1 );
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: