您的位置:首页 > 其它

PAT1117. Eddington Number

2018-03-12 14:08 363 查看

1117. Eddington Number(25)

时间限制250 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.Output Specification:For each case, print in a line the Eddington number for these N days.Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:
6
有E天骑行路程大于E ,求E的最大值//#include "stdafx.h"
#include"stdio.h"
#include<iostream>
#include<algorithm>

using namespace std;
typedef long long ll;
const int maxn=100010;

int a[maxn];

bool cmp(int a,int b){

return a>b;

}

int main(){

//freopen("c://jin.txt","r",stdin);
int n;
cin>>n;
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n,cmp);//将骑行的公里数按从大到小排列
int count=0;
for(int i=0;i<n;i++)//如果a[i]>i+1,那么a[i-1],a[i-2]……a[0]一定也是大于i+1的
if(a[i]>i+1)count++;
cout<<count<<endl;

freopen("CON","r",stdin);
system("pause");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: