您的位置:首页 > 其它

1241Oil Deposits(DFS入门好题,解决连通块的问题)

2018-03-02 08:33 309 查看
题目链接 点击打开链接
题目:
[align=left]Problem Description[/align]The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 
[align=left]Input[/align]The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 
[align=left]Output[/align]For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 
[align=left]Sample Input[/align]
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0  
[align=left]Sample Output[/align]
0
1
2
2题目大意:题目大意:有一块m*n油田,’@‘认为是有油,’*‘认为没油,如果有多块油田连着,则被统一认为为一块油田,一块油田可以有上,下,左,右,左上,右上,左下,右下8个方位,问一共有多少块油田。
题目思路:这个不像原来的解答树,这种结构,一种新的类型,解决连通块的问题
                从(0,0)点开始搜索,如果说这块是‘@’,搜索以这个点为根节点的一整棵树,那么就进行深搜把八个方向搜寻找一遍,并把搜到所有的‘@’都变成‘*’,然后计数加1;

                
#include<iostream>// http://blog.csdn.net/u011346442/article/details/42566965 #define N 105
using namespace std;
char pit

;//保存读取图形
int dir[8][2]={-1,0,-1,1,0,1,1,1,1,0,1,-1,0,-1,-1,-1};//表示八个方向
int m,n;//m 长度 n 宽度
void dfs(int x,int y)
{
if(pit[x][y]=='*'||x<0||x>=m||y<0||y>=n)
return ;
pit[x][y]='*';
for(int i=0;i<8;i++)
{
// x+=dir[i][0]; 一开始这儿有毛病 如果我在这儿加上 dir[i][0] x就变成了累加 就不是向八个方向在走了
// y+=dir[i][1];
dfs(x+dir[i][0],y+dir[i][1]);

}
}
int main()
{
int cnt=0;
while(cin>>m>>n&&(n||m))
{
cnt=0;
for(int i=0;i<m;i++)
cin>>pit[i];
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
if(pit[i][j]=='@')
{
dfs(i,j);
cnt++;
}
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  深搜 DFS