您的位置:首页 > 产品设计 > UI/UE

PAT (Advanced Level)1017. Queueing at Bank (25) 运算符的重载

2018-02-27 23:37 447 查看
题目链接

1017. Queueing at Bank (25)

时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.Input Specification:Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.Output Specification:For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
代码来源此处//1017. Queueing at Bank(25)

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1e3 + 10;
int n, m, t[maxn]/*用来存储每个窗口的时间*/, a, b, c, d, ans, cnt;
struct point
{
int x, y;
point(int x = 0, int y = 0) :x(x), y(y) {}
bool operator<(const point&a)const { return x < a.x; }//应用于sort函数,只对到达时间x进行递增排序
}f[maxn * 10];

int main()
{
scanf("%d%d", &n, &m);
for (int i = 0; i < n; i++)
{
scanf("%d:%d:%d%d", &a, &b, &c, &d);
f[i] = point(a * 3600 + b * 60 + c, d * 60);
}
sort(f, f + n);
for (int i = 0; i < m; i++) t[i] = 480 * 60;//每个窗口的开始时间为8点
for (int i = 0; i < n; i++)
{
if (f[i].x >= 17 * 60 * 60) break;//17点之后来的,不予服务
int now = 0;
for (int j = 1; j < m; j++)
{
if (t[j] < t[now]) now = j;//寻求哪个窗口可以最先结束
}
if (t[now]>f[i].x) //如果结束时间晚于i的到达时间(顾客到达时间已经进行了递增排序)
ans += t[now] - f[i].x;//给予i服务,总等待时间增加
t[now] = max(t[now], f[i].x) + f[i].y;
cnt++;//计算实际在17点前能来的人,即能轮到服务的人
}
if (cnt) printf("%.1lf\n", ans / (60.0*cnt)); else printf("0.0\n");
return 0;
4000
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: