您的位置:首页 > 产品设计 > UI/UE

【PAT】【Advanced Level】1017. Queueing at Bank (25)

2017-07-15 20:20 337 查看


1017. Queueing at Bank (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a
window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the
processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:
8.2


原题链接:

https://www.patest.cn/contests/pat-a-practise/1017

https://www.nowcoder.com/questionTerminal/e15d6a86f9ef4c43ae3a286196c3b5da

思路:

模拟

坑点:

等待时间截止到开始办理

17点之后的处理

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#define N 10010
#define K 110
using namespace std;

typedef struct S
{
string t;
int tt;
int p;
int wa;
};
typedef struct T
{
int num;
int rest;
};
S pas
;
T ser[K];

bool cmp(S a, S b)
{
return a.t<b.t;
}

int main()
{
int n,k;
cin>>n>>k;
for (int i=0;i<n;i++)
{
cin>>pas[i].t>>pas[i].p;
pas[i].tt=atoi(pas[i].t.substr(0,2).c_str())*3600+atoi(pas[i].t.substr(3,2).c_str())*60+atoi(pas[i].t.substr(6,2).c_str());
pas[i].tt-=3600*8;
pas[i].p*=60;
}
sort(pas,pas+n,cmp);
//for (int i=0;i<n;i++)cout<<pas[i].t<<" "<<pas[i].p<<" "<<pas[i].tt<<endl;
int no=0;
for (int i=0;i<k;i++)
{
if (no==n) break;
if (pas[no].t>"08:00:00") break;
pas[no].wa=0;
ser[i].num=no;
ser[i].rest=pas[no].p;
no++;
}
for (int i=1;i<=540*60;i++)
{
for (int j=0;j<k;j++)
{
if (ser[j].rest==0)
{
if (no==n) continue;
if (pas[no].tt>i) continue;
ser[j].rest=pas[no].p;
ser[j].num=no;
pas[no].wa=i;
no++;
continue;
}
ser[j].rest--;
if (ser[j].rest==0)
{
if (no==n) continue;
if (pas[no].tt>i) continue;
ser[j].rest=pas[no].p;
ser[j].num=no;
pas[no].wa=i;
no++;
}
}
}
int mm=0;
for (int i=0;i<k;i++)
{
if (ser[i].rest>mm) mm=ser[i].rest;
}
for (int i=540*60+0;i<540*60+mm;i++)
{
for (int j=0;j<k;j++)
{
if (ser[j].rest==0)
{
if (no==n) continue;
if (pas[no].tt>3600*9) continue;
mm=max(mm,i+pas[no].p);
ser[j].rest=pas[no].p;
ser[j].num=no;
pas[no].wa=i;
no++;
continue;
}
ser[j].rest--;
if (ser[j].rest==0)
{
if (no==n) continue;
if (pas[no].tt>3600*9) continue;
mm=max(mm,i+pas[no].p);
ser[j].rest=pas[no].p;
ser[j].num=no;
pas[no].wa=i;
no++;
continue;
}
}
}
//cout<<no<<" "<<n<<endl;
int ree=0;
for (int i=0;i<no;i++)
{

//cout<<(pas[i].wa-pas[i].tt)/60<<endl;
ree+=(pas[i].wa-pas[i].tt);
}
double ress=ree/(60.0*no);
printf("%.1f",ress);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: