您的位置:首页 > 其它

POJ 1703 Find them, Catch them 并查集 (关系问题 判断是否在一个集合)

2018-02-19 10:38 471 查看
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 
Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output

Not sure yet.
In different gangs.
In the same gang.
题意: N个人,M次操作 若是A 则判断二者的关系,若是D 则确认二者不是同一阵营.
思路:并查集,之间的大多题目都是判断是否处于同一连通分量,这次则是判断是否处于同一集合,

所以还需要一个数组存储与根节点的关系
(此题目与POJ 1182食物链 类似)#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int N = 100005;
int parent
; //存贮节点
int r
; //存贮关系 0同 1异
int root(int x)
{
if(x==parent[x]) return x;
int t=parent[x];
parent[x]=root(parent[x]);
r[x]=(r[x]+r[t])%2; //根据子节点和父亲节点的,父亲节点和爷爷节点的关系,推导子节点和爷爷节点的关系
return parent[x];
}
void make(int x,int y)
{
int fx=root(x);
int fy=root(y);
parent[fx]=fy;
r[fx]=(r[x]+1+r[y])%2;//fx与x关系 + x与y的关系 + y与fy的关系 = fx与fy的关系
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++){
parent[i]=i; //自己是自己的父节点
r[i]=0; //自己和自己属于同一类
}
char c;
int x,y;
while(m--)
{
getchar();
scanf("%c%d%d",&c,&x,&y);
if(c=='A'){
if(root(x)==root(y)){
if(r[x] != r[y]) printf("In different gangs.\n");
else printf("In the same gang.\n");
}
else printf("Not sure yet.\n");
}
else
make(x,y);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐