您的位置:首页 > 产品设计 > UI/UE

1099. Build A Binary Search Tree (30) PAT甲级刷题

2018-02-12 21:40 323 查看
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:The left subtree of a node contains only nodes with keys less than the node's key.The right subtree of a node contains only nodes with keys greater than or equal to the node's key.Both the left and right subtrees must also be binary search trees.Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.Output Specification:For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:58 25 82 11 38 67 45 73 42思路:先根据给好的数结构构建空树,然后中序遍历并插入数据,最后层序输出。#include <iostream>
#include <queue>
#include <algorithm>
using namespace std;

struct TNode{
int left;
int right;
int data;
};

void inorder(TNode tree[],TNode &t,int data[]){
static int i = 0;
if(t.left!=-1)
inorder(tree,tree[t.left],data);
t.data = data[i++];
if(t.right!=-1)
inorder(tree,tree[t.right],data);
}

int main()
{
int n;
cin>>n;
TNode tree[101];
int data[101];
for(int i=0;i<n;++i)
cin>>tree[i].left>>tree[i].right;
for(int i=0;i<n;++i)
cin>>data[i];
sort(data,data+n);
inorder(tree,tree[0],data);
cout<<tree[0].data;
queue<TNode> q;
q.push(tree[0]);
while(!q.empty()){
TNode t = q.front();
q.pop();
if(t.left!=-1){
cout<<' '<<tree[t.left].data;
q.push(tree[t.left]);
}
if(t.right!=-1){
cout<<' '<<tree[t.right].data;
q.push(tree[t.right]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c 编程练习