您的位置:首页 > 其它

1004. Counting Leaves (30)

2016-08-18 22:08 253 查看
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family memberswho have no child.InputEach input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children,followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.OutputFor each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the endof each line.The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.Sample Input
2 1
01 1 02
Sample Output
0 1
思路:把树当做图存储在邻接矩阵中;然后广度优先遍历邻接矩阵;
需要注意的是多push了一个0作为分隔层与层的标志
代码如下:
#include <iostream>
#include<queue>

using namespace std;
#define MAX 101
//根节点是从1开始的,所以数组也按找这样去存
int map[MAX][MAX] = {0};
int i;
int visit_isleaf(int aa)
{
for (int k = 1;k < MAX;k++)
{
if (map[aa][k] == 1)
return 0;
}
return 1;
}
void bfs()
{
queue<int > q;
q.push(1);
q.push(0);
int counter = 0;
while (!q.empty())
{
int temp = q.front();
q.pop();
if (temp == 0)
{
if (q.empty())
{
cout << counter;
break;
}
else
{
q.push(0);
cout << counter<<" ";
counter = 0;
}
}
else
{
counter += visit_isleaf(temp);
for (i = 1;i < MAX;i++)
{
if (map[temp][i] == 1)
{

q.push(i);
}
}
}
}
}

int main()
{
int n, m;
cin >> n >> m;
for ( i = 0;i < m;i++)
{
int id, k;
cin >> id >> k;
for (int j = 0;j < k;j++)
{
int id2;
cin >> id2;
map[id][id2] = 1;
}
}

bfs();

return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT