您的位置:首页 > 其它

POJ 3279 Fliptile(反转+二进制枚举)

2018-02-10 14:27 375 查看
Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:13542 Accepted: 4983
DescriptionFarmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.
As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.
Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".
InputLine 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for whiteOutputLines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.Sample Input4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1Sample Output0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0如果先假设第一行的操作数已经确定,接下来操做第二行,
假设现在第一行的第二个元素还不满足条件,那么只有通过
操作第二行第二个元素来改变,以此类推。因此一旦第一行操作
确定了,那么本次所有的操作便唯一确定,剩下的只需求出
操作数即可。因为对同一个地方操作两次跟没有操作是一样的。
操作三次跟一次是一样的,因此一个地方其实只有操作一次
或不操作两种选择,对第一行的每种情况进行枚举,一共
2^n中情况,每种情况可以在k*n*m的时间内完成(k是常数,这里大约是5)
因此这个的复杂度5*n*m*2^n可以在规定时间内求出。

代码:

#include<cstdio>
#include<string>
#include<string.h>
using namespace std;
int n,m,t[20][20],op[20][20];
int p[20][20],d[5][2]= {{0,0},{1,0},{-1,0},{0,1},{0,-1}};
bool yes(int x,int y)
{
int ans=t[x][y];
for(int i=0; i<5; i++)
{
int xx=x+d[i][0],yy=y+d[i][1];
if(xx<0||xx>=n||yy<0||yy>=m)continue;
ans+=p[xx][yy];
}
if(ans&1)return 0;
return 1;
}
int campulate()
{
int i,j;
for(i=1; i<n; i++)
{
for(j=0; j<m; j++)
{
if(!yes(i-1,j))//如果上一个不满足条件,则在此处操作
p[i][j]=1;
}
}
for(i=0; i<m; i++)
if(!yes(n-1,i))
return -1;
int res=0;
for(i=0; i<n; i++)
for(j=0; j<m; j++)
res+=p[i][j];
return res;
}
int main()
{
int i,j;
scanf("%d%d",&n,&m);
for(i=0; i<n; i++)
for(j=0; j<m; j++)
scanf("%d",&t[i][j]);
int res=1e9;
for(i=0; i<1<<m; i++)
{
memset(p,0,sizeof(p));
for(j=0; j<m; j++)
{
p[0][j]=i>>j&1;//二进制枚举子集
}
int num=campulate();
if(num!=-1&&num<res)
{
res=num;
memcpy(op,p,sizeof(p));
}
}
if(res==1e9)printf("IMPOSSIBLE\n");
else
{
for(i=0;i<n;i++)
{
for(j=0;j<m-1;j++)
printf("%d ",op[i][j]);
printf("%d\n",op[i][j]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: