您的位置:首页 > 其它

In how many ways can we select some of these coins so that they are X yen in total?

2018-02-07 13:40 1176 查看

Problem Statement

You have A
500-yen coins,
B
100-yen coins and
C
50-yen coins (yen is the currency of Japan). In how many ways can we select some of these coins so
that they are X yen in total?

Coins of the same kind cannot be distinguished. Two ways to select coins are distinguished when, for some kind of coin, the numbers of that coin are different.

Constraints

0≤A,B,C≤50
A+B+C≥1
50≤X≤20
000
A,
B and
C are integers.
X is a multiple of
50.

Input

Input is given from Standard Input in the following format:

A
B
C
X


Output

Print the number of ways to select coins.

Sample Input 1

2
2
2
100


Sample Output 1

2

There are two ways to satisfy the condition:

Select zero 500-yen coins, one
100-yen coin and zero
50-yen coins.
Select zero 500-yen coins, zero
100-yen coins and two
50-yen coins
代码:

import java.util.Scanner;

public class Main {

    public static void main(String[] args){

     int A,B,C,X;

     Scanner scan=new Scanner(System.in);

     //System.out.print("Please input a,b,c,x");

      A=scan.nextInt();

      B=scan.nextInt();

      C=scan.nextInt();

      X=scan.nextInt();

     int count=0;

     for(int i=0;i<=A;i++){

      for(int j=0;j<=B;j++){

       for(int k=0;k<=C;k++){

         int total=(i*500)+(j*100)+(k*50);

           if(total==X){

            count++;

           }

       }       

      }

     }

     System.out.print(count);

    }

}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐