您的位置:首页 > 其它

How many items that are double some other item

2017-03-14 23:33 405 查看
Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program
to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which
is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0

2 4 8 10 0

7 5 11 13 1 3 0

-1

Sample Output

3

2

0

解题思路:

用vector容器存放输入的数字,然后求值时,用双重循环逐个处理

细节处理:

注意最后不要将最后的0放入向量,以免影响处理,还有就是每重

循环后清空向量

代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
vector<double> a; double c;
while(1)
{
int sum=0;
while(cin>>c)
{
if(c==-1)
{a.push_back(c);break;}
if(c==0) break;
a.push_back(c);
}
if(c==-1) break;
int i,j;
for(i=0;i<a.size();i++)
for(j=0;j<a.size();j++)
if(a[j]*2==a[i]) sum++;
cout<<sum<<endl;
a.clear();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: