您的位置:首页 > 其它

#BFS# POJ 3126 Prime Path

2018-02-05 00:24 423 查看
POJ 3126

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.

— It is a matter of security to change such things every now and then, to keep the enemy in the dark.

— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!

— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.

— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!

— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.

— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.

— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.

— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?

— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033

1733

3733

3739

3779

8779

8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3

1033 8179

1373 8017

1033 1033

Sample Output

6

7

0

题目大意:

求素数a到素数b的最短路径距离,每次只能改变四位数中的一位数字,求最小花费。

解题思路:

先预处理求出所有素数,然后BFS找最短路径。对于一个四位数,如1033,它的千位可以从1-9取值,百位、十位、个位可以从0-9取值,然后在所有可以到达的状态中筛选符合条件(是素数和未被标记)的进队列。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <queue>
using namespace std;
const int MaxN = 1e5;

struct point {
int x, t;
};

queue <point> que;
int f[MaxN], vis[MaxN], w[4];  //f用来存素数,w用来存四位数的个十百千位
int a, b;
point S;  //起点

bool judge(int x) {  //判断是否为素数
for(int i = 2; i <= x / 2; i++)
if(x % i == 0) return 0;
return 1;
}
void bfs() {
S.x = a, S.t = 0;
que.push(S);
vis[S.x] = 1;
point now;
while(!que.empty()) {
now = que.front();
que.pop();
if(now.x == b) {  //如果弹出的数是想要到达的状态,输出步数
cout << now.t << endl;
return;
}
int step = now.t;
for(int i = 0; i < 4; i++) {  //存个十百千位
w[i] = now.x % 10;
now.x /= 10;
}
for(int i = 1; i <= 9; i++) {
now.x = w[3] * 1000 + w[2] * 100 + w[1] * 10 + i;  //对个位进行更改
if(f[now.x] == 1 && vis[now.x] == 0) {
vis[now.x] = 1;
now.t = step + 1;
que.push(now);
}
}
for(int i = 0; i <= 9; i++) {
now.x = w[3] * 1000 + w[2] * 100 + i * 10 + w[0];  //十位
if(f[now.x] == 1 && vis[now.x] == 0) {
vis[now.x] = 1;
now.t = step + 1;  //注意:这里要对之前存的step加一,不能直接对now.t本身加一!!!这我卡了好久才发现
que.push(now);
}
}
for(int i = 0; i <= 9; i++) {
now.x = w[3] * 1000 + i * 100 + w[1] * 10 + w[0];  //百位
if(f[now.x] == 1 && vis[now.x] == 0) {
vis[now.x] = 1;
now.t = step + 1;
que.push(now);
}
}
for(int i = 1; i <= 9; i++) {
now.x = i * 1000 + w[2] * 100 + w[1] * 10 + w[0];  //千位
if(f[now.x] == 1 && vis[now.x] == 0) {
vis[now.x] = 1;
now.t = step + 1;
que.push(now);
}
}
}
cout << "Impossible" << endl;
}
int main() {
memset(f, 0, sizeof(f));
for(int i = 1001; i <= 9997; i++)  //预处理找出所有素数
if(judge(i)) f[i] = 1;
int t;
cin >> t;
while(t--) {
while(!que.empty()) que.pop();
memset(vis, 0, sizeof(vis));
cin >> a >> b;
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj bfs