您的位置:首页 > 其它

Sum of Consecutive Prime Numbers POJ - 2739 素数打表—埃氏筛法

2018-01-26 16:18 399 查看
Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13
+ 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.

Your mission is to write a program that reports the number of representations for the given positive integer.

Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output
The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No
other characters should be inserted in the output.
Sample Input
2
3
17
41
20
666
12
53
0

Sample Output
1
1
2
3
0
0
1
2


题意:给定n值,求连续一段素数能加成n的方法数。

埃氏筛法的复杂度为O(nlognlogn),可以看做大致为线性的。。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int M=1e4+10;
int p;
int prime[M];
bool is_prime[M];
void init()//埃氏筛法
{
p=0;
for(int i=0;i<=M;i++)
is_prime[i]=true;
is_prime[0]=is_prime[1]=false;
for(int i=2;i<=M;i++)
{
if(is_prime[i])
{
prime[p++]=i;//统计区间素数的个数
for(int j=2*i;j<=M;j+=i)
is_prime[j]=false;
}
}
}
int main()
{
int n;
init();
sort(prime,prime+p);
while(~scanf("%d",&n),n)
{
int cnt=0,j=0,t;
for(int i=0;i<p;i++)
{
j=i;t=prime[i];
if(t>n)
break;
while(t+prime[j+1]<=n&&j<p)
{
j++;
t+=prime[j];
// printf("%d ",t);
}

if(t==n)
cnt++;
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: