您的位置:首页 > 其它

POJ 2739 E - Sum of Consecutive Prime Numbers 素数打表+尺取法

2016-12-10 20:15 387 查看
Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13
+ 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 

Your mission is to write a program that reports the number of representations for the given positive integer.

Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output
The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No
other characters should be inserted in the output.

Sample Input
2
3
17
41
20
666
12
53
0


Sample Output
1
1
2
3
0
0
1
2
思路:这个题还是比较好想的,我们只需要素数打表然后由于是连续的,符合尺取法条件,然后套模板就可以了
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define N 10010
using namespace std;
int a
,prime
,p;
void prim()
{    int i,j;
     for(i=2;i<=N;i++)
       a[i]=1;
     for(i=2;i<=N;i++)
     {   if (a[i]!=0)
         {   prime[p++]=i;
             for(j=i;j<=N;j=j+i)
              a[j]=0;
}
}
return ;
}
int solve(int ss)
{      int i,t=0,s=0,sum=0,k=0;
        for(i=0;i<p;i++)
{   
  if(prime[i]>ss)
    break; 
       while(t<p&&sum<ss)
       sum+=prime[t++];
       if(sum==ss)
       k++;
       sum-=prime[s++];
      if(t==p)
      break;
  } 
  return k;
}
int main()
{      int n,count;
       p=0;
       prim();
       while(scanf("%d",&n)!=EOF)
       {     if(n==0)
              break;
            count=solve(n);
            printf("%d\n",count);
  }
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm