您的位置:首页 > 其它

stl的map2------[NWPU][2018寒假作业][通用版]二、stl ,模拟,贪心等 [Cloned]B题

2018-01-25 10:59 393 查看
Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i’m fiwo riwosf.

i fiiwj fnnvk!

END

Sample Output

hello, i’m from mars.

i like earth!

Hint

Huge input, scanf is recommended.

解题思路:

前面的字典部分,用map

#include<iostream>
#include<map>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;

int main()
{
string t,m,e,tran;
map<string,string> dict;
while(1)
{
cin>>t;
while(1)
{
cin>>m;
if(m=="END")
{
break;
}
cin>>e;
dict[e]=m;
}
cin>>t;
tran="";
getchar();
char sen[3010]={0};
while(1)
{
gets(sen);
if(strcmp(sen,"END")==0)
{
return 0;
}
int len=strlen(sen);
for(int i=0;i<len;i++)//遍历这个句子
{
if(sen[i]<'a'||sen[i]>'z')
//当前字符不是字母,证明单词结束
{
if(dict[tran]!="")
{//如果字典中有这个单词,输出对应字符串
cout<<dict[tran];
}
else
{//字典中没有这个单词,则输出单词
cout<<tran;
}
tran="";//情况字符串,准备储存下一个单词
cout<<sen[i];//输出当前不是字母的字符
}
else//当前字符是字母时
{
tran+=sen[i];//将字母存到字符串中
}
}
cout<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  stl map
相关文章推荐