您的位置:首页 > 其它

[LIS_最长递增子序列]-hdu 1087 Super Jumping!

2018-01-22 15:02 274 查看

[LIS_最长递增子序列]-hdu 1087 Super Jumping!

标签: ACM

题意:

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

output

For each case, print the maximum according to rules, and one line one case.

sample input

3 1 3 2

4 1 2 3 4

4 3 3 2 1

0

sample output

4

10

3

解题思路:

**dp[i]为以a[i]结尾的最大递增子列和 ,

dp[i]=a[i]; if(a[j] < a[i]) dp[i]=max(dp[j]+a[i],dp[i]); (0<=j< i)

从左到右求最大递增子序列,时间复杂度为O(n^2)**

AC代码:

#include <iostream>
#include <stdio.h>
#define MAX 1000005
using namespace std;

int t,n;
int a[MAX];
int dp[MAX];
int main()
{
scanf("%d",&t);
for(int x=1;x<=t;x++)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
dp[
4000
1]=a[1];
for(int i=2;i<=n;i++)
{
if(dp[i-1]<0)
dp[i]=a[i];
else
dp[i]=dp[i-1]+a[i];
}
int maxs=dp[1];
int l=1,r=1;
for(int i=1;i<=n;i++)
{
if(dp[i]>maxs)
{
maxs=dp[i];
r=i;
}
}
for(int i=r;i>=1;i--)
{
if(dp[i]<0)
{
l=i+1;
break;
}
}
if(l>r)l=r;
printf("Case %d:\n%d %d %d\n",x,maxs,l,r);
if(x!=t)
printf("\n");
}
return 0;
}


不懂的可以留言
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: