您的位置:首页 > 其它

HDU1087 Super Jumping! Jumping! Jumping! DP求非连续单调递增序列的最大和

2016-04-16 23:49 471 查看


Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31616    Accepted Submission(s): 14206


Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

 

Input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N 

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the maximum according to rules, and one line one case.

 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

 

Sample Output

4
10
3

 

题意:求非连续单调递增序列的最大和

思路:看别人写的代码,大多数人dp[i]代表以第i个为结束,我第一感觉是想以规定起点来dpint dp[1009];//以第i个点为起点的最大值
然后从后往前更新dp[i]。

if(A[j]>A[i])dp[i]=max(dp[i],dp[j]+A[i]);


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <time.h>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int N;
int A[1009];
int dp[1009];//以第i个点为起点的最大值
int ans;
int main(){
while(scanf("%d",&N)&&N!=0){
ans=0;
for(int i=0;i<N;i++){
scanf("%d",&A[i]);
}

for(int i=N-1;i>=0;i--){
dp[i]=A[i];
for(int j=i+1;j<N;j++){
if(A[j]>A[i]){
dp[i]=max(dp[i],dp[j]+A[i]);
}
}
ans=max(ans,dp[i]);
}

cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: