您的位置:首页 > 其它

HDU 1061 Rightmost Digit 【快速幂】

2018-01-12 09:55 357 查看

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 61561    Accepted Submission(s): 23078


[align=left]Problem Description[/align]
Given a positive integer N, you should output the most right digit of N^N.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

[align=left]Output[/align]
For each test case, you should output the rightmost digit of N^N.

 

[align=left]Sample Input[/align]

2
3
4

 

[align=left]Sample Output[/align]

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

#include<bits/stdc++.h>
using namespace std;
#define ll long long
ll Pow(ll a, ll b)
{
ll ans = 1;
while(b)
{
if(b & 1)
ans = ans * a % 10;
a = a * a % 10;
b >>= 1;
}
return ans;
}
int main()
{
int N;
cin >> N;
while(N--)
{
ll x;
cin >> x;
int z = Pow(x, x);
cout << z % 10 <<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: