您的位置:首页 > 其它

POJ 2387 Til the Cows Come Home(最短路,Dijkstra算法)

2018-01-01 10:07 513 查看

Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 61505 Accepted: 20865

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

Line 1: Two integers: T and N

Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5

1 2 20

2 3 30

3 4 20

4 5 20

1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

暑假集训时学的迪杰斯特拉算法,听的云山雾罩,数据结构学完后有了新的认识,写了这道模板题。

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int a[1010][1010];  //a[i][j]表示从i-->j的距离
int Dis[1010];      //dist[i]从v1到i的距离
int vis[1010];      //标记有没有被访问过
void dijkstra(int n)
{
int Min;
for(int i=1; i<=n; i++)
{
Dis[i]=a[1][i];
}
for(int i=1; i<=n; i++)
{
Min=INF;
int k=0;
for(int j=1; j<=n; j++)
{
if(!vis[j] && Dis[j]<Min)
{
Min=Dis[j];     //选择一条当前最短路径
k=j;
}
}
vis[k]=1;
for(int j=1; j<=n; j++)
{
if(!vis[j] && Dis[k] + a[k][j] < Dis[j])
{
Dis[j] = Dis[k] + a[k][j];
}
}
}
return ;
}
int main()
{
int T,N;
scanf("%d %d",&T,&N);
memset(Dis,0,sizeof(Dis));
memset(vis,0,sizeof(vis));
for(int i=1; i<=N; i++)
for(int j=1; j<=N; j++)
a[i][j]=INF;//初始化为无穷大
while(T--)
{
int x,y,value;
scanf("%d %d %d",&x,&y,&value);
if(value<a[x][y])
a[x][y]=a[y][x]=value;
}
dijkstra(N);
printf("%d\n",Dis
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dijkstra