您的位置:首页 > 其它

POJ 2387 Til the Cows Come Home【最短路】

2018-02-05 22:02 316 查看
Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 63291 Accepted: 21379
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.
#include<iostream>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
#define MAX 1005
#define mms(x) memset(x, 0, sizeof x)
int maps[MAX][MAX], d[MAX];
int n, m;
void dijkstra()
{
int minn, v;
mms(d);
bool vis[MAX];
for(int i = 1; i <= n; i++)
{
vis[i] = 0;
d[i] = maps[1][i];
}
for(int i = 1; i <= n; i++)
{
minn = INF;
for(int j = 1; j <= n; j++)
if(!vis[j] && d[j] < minn)
{
v = j;
minn = d[j];
}
vis[v] = 1;
for(int j = 1; j <= n; j++)
if(!vis[j])
d[j] = min(d[j], maps[v][j] + d[v]);
}
}
int main()
{
while(cin >> m >> n)
{
for(int i = 1; i <= n; i++)
for(int j = 1; j <= n; j++)
maps[i][j] = INF;
for(int i = 0, x, y, z; i < m; i++)
{
cin >> x >> y >> z;
maps[x][y] = maps[y][x] = min(maps[x][y], z);
}
dijkstra();
cout << d
<< endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: