您的位置:首页 > 其它

ZOJ-1586 QS Network (最小生成树)

2017-12-26 14:44 369 查看
QS Network
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please
be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the
group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.
A sample is shown below:



A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.
Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand
of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input
The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.
Constrains:
all the integers in the input are non-negative and not more than 1000.

Output
for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input
1

3

10 20 30

0 100 200

100 0 300

200 300 0

Sample Output
370

#include <stdio.h>
#include <algorithm>
using namespace std;
struct edge{
int from, to, val;
bool operator < (const edge& x) const{
return val < x.val;
}
}e[1001111];
int p[1111], y[1011], a[1001][1001];
int findset(int x){
return p[x] == x ? x : p[x] = findset(p[x]);
}
int main(){
int T;
scanf("%d", &T);
while(T--){
int n, m, u, v, w, num;
scanf("%d", &n);
for(int i = 1; i <= n; ++i){
scanf("%d", &y[i]);
}
for(int i = 1; i <= n; ++i){
for(int j = 1; j <= n; ++j){
scanf("%d", &a[i][j]);
}
}
num = 0;
for(int i = 1; i <= n; ++i){
for(int j = i + 1; j <= n; ++j){
e[++num].from = i;
e[num].to = j;
e[num].val = a[i][j] + y[i] + y[j];
}
}
sort(e + 1, e + 1 + num);
int ans = 0;
for(int i = 1; i <= n; ++i){
p[i] = i;
}
for(int i = 1; i <= num; ++i){
u = findset(e[i].from);
v = findset(e[i].to);
if(u != v){
p[u] = v;
ans += e[i].val;
}
}
printf("%d\n", ans);
}
}

/*
题意:
1000个点,各处每两个点之间的边权,建边的同时需要在点上都建一个发射站?求最小生成树。

思路:
发射站的代价需要提前加到边权代价里再排序,先排序边权然后跑最小生成树再加发射站代价是错的。
并查集维护一下集合,对所有边扫一遍即可。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息