您的位置:首页 > 其它

【poj1743】Musical Theme 后缀数组/不可重叠最长重复子串 + 双指针扫描

2017-11-23 11:46 134 查看
Musical Theme

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31535 Accepted: 10511
Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this
programming task is about notes and not timings. 

Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
is at least five notes long 

appears (potentially transposed -- see below) again somewhere else in the piece of music 

is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 

Given a melody, compute the length (number of notes) of the longest theme. 

One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 

The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.
Sample Input
30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output
5

Hint

Use scanf instead of cin to reduce the read time.
Source

LouTiancheng@POJ
[Submit]   [Go Back]   [Status]  
[Discuss]

不可重叠最长重复子串

先二分答案,把题目变成判定性问题:判断是否存在两个长度为 k 的子串是相同的,且不重叠。

把排好序的字符串分组,每组的字符串的height值都大于等于len,然后判断每组中的sa最大值和最小值之差是否大于等于len

这里分组的时候需要双指针扫描.

bool check(int len)
{
int l,r;
l = 2,r=2;
while(l<=n&&r<=n)
{
if(height[l]<len)
{
l++;
continue;
}
if(height[l]>=len)
{
r=l;
while(height[r]>=len && r<=n) r++;
}
int maxx=sa[l],minn=sa[l];
for(int i=l-1;i<r;i++)
{
maxx = max(maxx,sa[i]);
minn = min(minn,sa[i]);
}
if(maxx-minn>=len)
{
return true;
}
l=r;
}
// cout <<"len : "<<len<<endl;
return false;
}

完整代码如下:

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<set>
#include<ctime>
#include<vector>
#include<cmath>
#include<algorithm>

using namespace std;
typedef long long ll;
const int MAXN = 20005;
/*
*suffix array
*倍增算法 O(n*logn)
*待排序数组长度为n,放在0~n-1中,在最后面补一个0
*build_sa( ,n+1, );//注意是n+1;
*getHeight(,n);
*例如:
*n = 8;
*num[] = { 1, 1, 2, 1, 1, 1, 1, 2, $ };注意num最后一位为0,其他大于0
*rank[] = { 4, 6, 8, 1, 2, 3, 5, 7, 0 };rank[0~n-1]为有效值,rank
必定为0无效值
*sa[] = { 8, 3, 4, 5, 0, 6, 1, 7, 2 };sa[1~n]为有效值,sa[0]必定为n是无效值
*height[]= { 0, 0, 3, 2, 3, 1, 2, 0, 1 };height[2~n]为有效值
*
*/

int sa[MAXN];//SA数组,表示将S的n个后缀从小到大排序后把排好序的
//的后缀的开头位置顺次放入SA中
int t1[MAXN],t2[MAXN],c[MAXN];//求SA数组需要的中间变量,不需要赋值
int rank1[MAXN],height[MAXN];
//待排序的字符串放在s数组中,从s[0]到s[n-1],长度为n,且最大值小于m,
//除s[n-1]外的所有s[i]都大于0,r[n-1]=0
//函数结束以后结果放在sa数组中
void build_sa(int s[],int n,int m)
{
int i,j,p,*x=t1,*y=t2;
//第一轮基数排序,如果s的最大值很大,可改为快速排序
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[i]=s[i]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
for(j=1;j<=n;j<<=1)
{
p=0;
//直接利用sa数组排序第二关键字
for(i=n-j;i<n;i++)y[p++]=i;//后面的j个数第二关键字为空的最小
for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
//这样数组y保存的就是按照第二关键字排序的结果
//基数排序第一关键字
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[y[i]]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
//根据sa和x数组计算新的x数组
swap(x,y);
p=1;x[sa[0]]=0;
for(i=1;i<n;i++)
x[sa[i]]=y[sa[i-1]]==y[sa[i]] && y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
if(p>=n)break;
m=p;//下次基数排序的最大值
}
}
void getHeight(int s[],int n)
{
int i,j,k=0;
for(i=0;i<=n;i++)rank1[sa[i]]=i;
for(i=0;i<n;i++)
{
if(k)k--;
j=sa[rank1[i]-1];
while(s[i+k]==s[j+k])k++;
height[rank1[i]]=k;
}
}

int str[MAXN];
int s[MAXN];
int n;
bool check(int len)
{
int l,r;
l = 2,r=2;
while(l<=n&&r<=n)
{
if(height[l]<len)
{
l++;
continue;
}
if(height[l]>=len)
{
r=l;
while(height[r]>=len && r<=n) r++;
}
int maxx=sa[l],minn=sa[l];
for(int i=l-1;i<r;i++)
{
maxx = max(maxx,sa[i]);
minn = min(minn,sa[i]);
}
if(maxx-minn>=len)
{
return true;
}
l=r;
}
// cout <<"len : "<<len<<endl;
return false;
}

int main()
{
// freopen("data.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(~scanf("%d",&n)&&n)
{
for(int i=0;i<n;i++)
scanf("%d",&s[i]);
s
=0;

n--;

for(int i=0;i<n;i++)
{
s[i]=s[i+1]-s[i]+100;
}

s
=0;

build_sa(s,n+1,250);
getHeight(s,n);

int ans=0;
int l = 1;
int r = n;
while(l<=r)
{
// cout << l<<" " <<r<<endl;
int mid=(l+r)>>1;
if(check(mid))
ans=mid,l=mid+1;
else
r=mid-1;
}
if(ans<4)
{
printf("0\n");
}
else
{
printf("%d\n",ans+1);
}
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: