您的位置:首页 > 大数据 > 人工智能

HDU-2870 Largest Submatrix (线性dp 最大01矩阵)(2009 Multi-University Training Contest 7 )

2017-11-16 15:52 483 查看


Largest Submatrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2656    Accepted Submission(s): 1298


Problem Description

Now here is a matrix with letter 'a','b','c','w','x','y','z' and you can change 'w' to 'a' or 'b', change 'x' to 'b' or 'c', change 'y' to 'a' or 'c', and change 'z' to 'a', 'b' or 'c'. After you changed it, what's the largest submatrix with the same letters
you can make?

 

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 1000) on line. Then come the elements of a matrix in row-major order on m lines each with n letters. The input ends once EOF is met.

 

Output

For each test case, output one line containing the number of elements of the largest submatrix of all same letters.

 

Sample Input

2 4
abcw
wxyz

 

Sample Output

3

#include <bits/stdc++.h>
using namespace std;
int R, C, a[1001][1001], h[1001][1001], l[1001], r[1001];
char s[1001][1001];
int solve(int kind){
for(int i = 1; i <= R; ++i){
for(int j = 1; j <= C; ++j){
if(kind == 0){
if(s[i][j] == 'a' || s[i][j] == 'w' || s[i][j] == 'y' || s[i][j] == 'z') a[i][j] = 1;
else a[i][j] = 0;
}
if(kind == 1){
if(s[i][j] == 'b' || s[i][j] == 'w' || s[i][j] == 'x' || s[i][j] == 'z') a[i][j] = 1;
else a[i][j] = 0;
}
if(kind == 2){
if(s[i][j] == 'c' || s[i][j] == 'x' || s[i][j] == 'y' || s[i][j] == 'z') a[i][j] = 1;
else a[i][j] = 0;
}
}
}
for(int i = 1; i <= C; ++i){
h[0][i] = 0;
}
int ans = 0;
for(int i = 1; i <= R; ++i){
for(int j = 1; j <= C; ++j){
if(a[i][j] == 1){
h[i][j] = h[i - 1][j] + 1;
}
else{
h[i][j] = 0;
}
}
}
for(int i = 1; i <= R; ++i){
for(int j = 1; j <= C; ++j){
l[j] = r[j] = j;
}
h[i][0] = -1;
for(int j = 1; j <= C; ++j){
while(h[i][j] <= h[i][l[j] - 1]){
l[j] = l[l[j] - 1];
}
}
h[i][C + 1] = -1;
for(int j = C - 1; j >= 1; --j){
while(h[i][j] <= h[i][r[j] + 1]){
r[j] = r[r[j] + 1];
}
}
for(int j = 1; j <= C; ++j){
ans = max(ans, (r[j] - l[j] + 1) * h[i][j]);
}
}
return ans;

}
int main(){
while(scanf("%d %d", &R, &C) != EOF){
for(int i = 1; i <= R; ++i){
for(int j = 1; j <= C; ++j){
s[i][j] = getchar();
while(s[i][j] < 'a' || s[i][j] > 'z'){
s[i][j] = getchar();
}
}
}
int ans = 0;
ans = max(ans, solve(0));
ans = max(ans, solve(1));
ans = max(ans, solve(2));
printf("%d\n", ans);
}
}

/*
题意:
1000*1000的字符矩阵,字符只包含a,b,c,w,x,y,z,w,x,y,z可以做一些变化变成a或b或c,问最大只包含一种字符的
矩阵面积。

思路:
首先有一个观察,我们不用考虑包含w,x,y,z的矩阵情况,将他们转化成a或b或c处理即可。如果直接考虑怎么处理这些变化
然后计算矩阵面积比较麻烦,我们不妨分开处理,分别计算只包含a的情况,然后b,c,最后取最大值即可。
计算只包含a的情况那么就可以转换成01矩阵中最大1矩阵的问题。可以参考: http://blog.csdn.net/hmc0411/article/details/78540500; http://blog.csdn.net/hmc0411/article/details/78539159;
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息