您的位置:首页 > 大数据 > 人工智能

PAT - 甲级 - 1090. Highest Price in Supply Chain (25)(树的遍历DFS)

2017-11-12 10:49 435 查看
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root
supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price
given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for
the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the
price will not exceed 1010.
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:
1.85 2


给定要求:

1.n个节点以及之间的关系

要求:

1.根节点要叶子节点之间最远距离

解:

1.dfs遍历该树

#include<cstdio>
#include<cmath>
#include<vector>
using namespace std;

int n, root, cnt;
double r, p, maxP=-1;

vector<int> node[100001];

void dfs(int v, int d){
if(node[v].size() == 0){
double curP = p * pow((r+100.0)/100.0, d);
if(curP == maxP){
cnt++;
}
else if(curP > maxP){
cnt = 1;
maxP = curP;
}
return ;
}else{
for(int i = 0; i < node[v].size(); i++){
dfs(node[v][i], d+1);
}
}
}

int main(){
scanf("%d%lf%lf", &n, &p, &r);
cnt = 0;
int t;
for(int i = 0; i < n; i++){
scanf("%d", &t);
if(t == -1){
root = i;
continue;
}else{
node[t].push_back(i);
}
}
dfs(root,0);
printf("%.2f %d\n",maxP, cnt);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: